My personal project and infrastructure archive
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
nomicon/hardware/devices/euro-yesman-1u/shell.nix

12 lines
340 B

with (import <nixpkgs> {});
stdenv.mkDerivation {
name = "bad-rust-env";
buildInputs = with pkgs; [
# This shell file uses rustup to enable cross-compiling
# TODO: this should be fixed at some point; get an arm-rustc, etc
rustup rust-analyzer clangStdenv gcc-arm-embedded
cargo-flash cargo-binutils openocd
];
}