My personal project and infrastructure archive
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
nomicon/infra/corenix/pkgs/coreboot-payload-coreinfo/default.nix

15 lines
436 B

{ coreboot, lib, stdenv, writeText, coreinfoConfig ? { } }:
stdenv.mkDerivation rec {
pname = "coreboot-payload-coreinfo";
inherit (coreboot.drvAttrs) version src postPatch;
preConfigure = "cd payloads/coreinfo";
configurePhase = ''
runHook preConfigure
cp ${coreboot.writeConfig coreinfoConfig} .config
make olddefconfig
runHook postConfigure
'';
installPhase = "install -D build/coreinfo.elf -t $out";
}